Sie sind nicht angemeldet.

DerNeue87

Anfänger

  • »DerNeue87« ist der Autor dieses Themas

Beiträge: 5

Registrierungsdatum: 12.03.2011

Danksagungen: 55 / 0
(erhalten / vergeben)

  • Nachricht senden

1

12.03.2011, 00:46

Age of Empires 2 startet nicht.

Hallo PC Freunde,

ich musste mich hier Anmelden weil ich ein Problem hab mit dem bekannten Classiker Age of Empires 2 + Expansion. Und zwar läuft die Installation gut und er schließt sie erfolgreich ab. Aber wenn ich das Spiel starte kommt ganz normal das AoE Bild mit den Satz "es wird geladen" und man hört wie das Laufwerk arbeitet (aber nicht dieses "beschleunigungs" Geräusch). Dann geht das Bild weg und die CourserMaus zeigt an das sie was lädt, aber dann tut sich nichts mehr... also ich seh ganz normal den Desktop, es kommt [u]keine[/u] Fehlermeldung und er hängt sich [u]nicht[/u] auf. So als würde ich nichts dran machen... Habe Windows 7 64bit drauf. Hab schon einige Sachen probiert wie den KombiModus und so, aber nichts hilft weiter...
Kann mir einer sagen warum das Spiel nicht normal startet wie es sich gehört? Wieso kommt das "es wird geladen" Bild aber dann tut sich nichts mehr? Das Laufwerk arbeitet wie schon gesagt, aber macht diesen Typischen "bewegungs" Geräusche -.-
Ach so hab auch die Patches drauf...
PS: Grafikkarte zeigt auch kein Fehler und ZoneAlarm hab ich so eingestellt das alles von den AoE2 zugelassen ist.
MfG

DerNeue alias Mikel

Holger

Administrator

  • »Holger« ist männlich

Beiträge: 4 651

Registrierungsdatum: 16.10.2002

Wohnort: Leer/Emden/Aurich

Beruf: Ja, hab ich auch...

Hobbys: Alles, außer Computer ;-)

Danksagungen: 3099 / 7
(erhalten / vergeben)

  • Nachricht senden

2

12.03.2011, 09:55

Hallo und Willkommen im Forum.

AOE2 soll laut Berichten unter Windows 7 laufen und auch von der 64bit-Version unterstützt sein.

Nichtsdestotrotz ist es ein altes Spiel, wenn auch ein Klassiker den man immer mal wieder gerne spielt, und daher auch einigen Beschränkungen unterlegen.
Updates und Patches gibt es seitens Hersteller, skurrilerweise ja Microsoft selber, nicht mehr, die letzte aktulle Version ist definitiv die letzte, es kann also auch keine Verbesserungen,
Erweiterungen oder Unterstützung für zukünftige Kompatibilität geben.

Windows 7 Enterprise (64-bit) unterstützt das Spiel angeblich überhaupt nicht. Man kommt da bis ins Menue, wenn man aber eine neue Kampaign laden will sagt das Spiel "ha,ha" und man landet wieder auf dem Desktop.

So unterstützt AOE2 nur eine Auflösung von 800x600 mit 256Farben. Das kann eben zu Fehlfarben führen oder dazu daß das Spiel kein Bild hat. Neben den neuesten Grafikkartentreibern die installiert sein sollten
versucht man gerade an modernen TFT mal die Auflösung runterzuschrauben und die Farben auf 256 runterzuschrauben.

DirectX erstmal updaten und auch alle sonstigen Treiber auf den neuesten Stand bringen. Problem dabei: AOE2 ist für DirectX 5 und 6 gemacht. Auf der Spiel-CD ist die Version noch erhalten wird aber nicht installiert da die
vorhandene Versionsnummer auf dem PC viel neuer ist. Geh in den DirektX -Ordner der CD und installier die darauf vorhandene DX-Version von Hand.
Schau ob das Spiel jetzt startet.

Dann unbedingt die finalen Updates und Patches für AOE2 installieren. Die findest Du hier: AOE2 - Updates

Wie würde die ideale Vorgehensweise dann aussehen?
Eine saubere Windows 7 Installation
Aktuellste Video und Soundtreiber installieren
Alle Windows Updates installieren
Dann das Spiel installieren in der finalen Version und die DirektX-Version die mit dem Spiel kommt
Und dann das Spiel spielen.

Wie ich gerade lese soll jede DX-Version die nur 2 Releases über der der mit dem Spiel gelieferten das Spiel nicht mehr starten lassen.

Sag Bescheid wenn es geklappt hat! Möchtest Du Dich kurz vorstellen und Hallo zu den anderen sagen? Das kannst Du hier tun. Wir würden uns freuen!

Gruß
Holger
Signaturfreier Bereich! Außerdem....
wenn die Klügeren immer nachgeben, regieren am Ende die Dummen die Welt!

DerNeue87

Anfänger

  • »DerNeue87« ist der Autor dieses Themas

Beiträge: 5

Registrierungsdatum: 12.03.2011

Danksagungen: 55 / 0
(erhalten / vergeben)

  • Nachricht senden

3

12.03.2011, 12:54

Hi,

und Danke erstmal für deine schnelle Hilfe.
Also wenn ich die AoG2 CD Öffne und dann das DXSETUP.EXE anklicke zum Installieren kommt dann nur "DirectX erneut Insatllieren".
Wo ich das Updaten kann keine Ahnung.
Die Patches habe ich schon alle installiert.
Meine Windows 7 ist die Ultimate Version.

MfG
DerNeue --> Mikel

DerNeue87

Anfänger

  • »DerNeue87« ist der Autor dieses Themas

Beiträge: 5

Registrierungsdatum: 12.03.2011

Danksagungen: 55 / 0
(erhalten / vergeben)

  • Nachricht senden

4

12.03.2011, 13:13

Also hab nochmal geschaut und ich habe schon DirectX 11 drauf. Ist das nicht so geeignet?

Holger

Administrator

  • »Holger« ist männlich

Beiträge: 4 651

Registrierungsdatum: 16.10.2002

Wohnort: Leer/Emden/Aurich

Beruf: Ja, hab ich auch...

Hobbys: Alles, außer Computer ;-)

Danksagungen: 3099 / 7
(erhalten / vergeben)

  • Nachricht senden

5

12.03.2011, 14:24

Das Spiel macht ja wohl bei sehr vielen Besitzern Macken.

Die Tipps die ich gefunden habe ( ich habe das Spiel selber nicht da ich überhaupt nicht auf das Format stehe) sind teilweise
aus der englischen Knowledgebase von Microsoft selbst. Daher kann man nur nach der Methode try&error vorgehen.
DirectX kann man nicht downgraden und Windows 7 bringt Version 11 von Haus aus mit.
Irgendwann muss man sich halt von alten Zöpfen trennen, keiner kann sich 100 Jahre Support für alte Sachen leisten.

Trotzdem scheint das Spiel irgendwie unter WINSeven zu laufen. So wird geauso oft berichtet wie das Gegenteil wo viele es nicht zum laufen bekommen haben und darüber
aufgegeben haben.
Und Du hast ja woanders auch schon angefragt. Wenn es da noch zu keiner eindeutigen Lösung gekommen ist......besteht auch wohl nur eine 50:50 Chance.

Hast Du Zonealarm in Benutzung? Soll auch oft Probleme machen in Zusammenhang mit dem Spiel.
Hast Du das Spiel mal neu installiert? Hat auch einigen geholfen.
Kompatibilitätsmodus mal ausprobiert? Nicht vergessen das Du das auch als Administrator laufen lassen musst in dem fall.
Signaturfreier Bereich! Außerdem....
wenn die Klügeren immer nachgeben, regieren am Ende die Dummen die Welt!

DerNeue87

Anfänger

  • »DerNeue87« ist der Autor dieses Themas

Beiträge: 5

Registrierungsdatum: 12.03.2011

Danksagungen: 55 / 0
(erhalten / vergeben)

  • Nachricht senden

6

12.03.2011, 23:25

Hey Holger,

also habs nochmal Probiert im KombiModus + Als Admin, aber nix geschieht. Weiß auch nimmer weiter, hab den Virtuell PC mal geholt, entweder es geht da nicht oder ich hab kein plan was ich da machen muss :S Kenne mich mit PC nur gering aus :D

Ich muss mich trotzdem bedanken bei euch unb vll hast du recht, i-wann muss man sich davon trennen....
Ich verstehe nur nicht warum es nicht wie bei jedem anderen ist, das da ne Fehlermeldung kommt. Bei mir ist das nicht so. Bei mir kommt aufn Desktop ein kleines Fenster von AoE2 und da steht "es wird geladen" danach geht es weg und nichts ist mehr, als hätte ich keine Aktion durchgeführt....

MfG

DerNeue

Holger

Administrator

  • »Holger« ist männlich

Beiträge: 4 651

Registrierungsdatum: 16.10.2002

Wohnort: Leer/Emden/Aurich

Beruf: Ja, hab ich auch...

Hobbys: Alles, außer Computer ;-)

Danksagungen: 3099 / 7
(erhalten / vergeben)

  • Nachricht senden

7

13.03.2011, 10:08

Im Taskmanager wird der Prozess also angezeigt? Somit müsste die Ausführung möglich sein.
Du schreibst auch das Dein CD/DVD-Laufwerk anläuft, aber nicht wie gewohnt höhere Drehzahl fährt wie das bei Kopier- und Ladevorgängen ja
eigentlich üblich ist.

Möglich das bei Dir einfach nur folgendes Problem von dem auch berichtet wird auftritt:

Quellcode

1
2
3
Fehler 1 [WIN7]: Age of Empires 2 startet nicht aber im Taskmanager läuft die Anwendung auf 50-100% CPU-Last
Unter Windows 7 scheint Age of Empires 2 massiv Probleme mit der CD-Erkennung durch DVD/CD-Laufwerken zu haben. 
Vor allem auf Notebooks scheint dieser Fehler häufig aufzutreten.


Dazu gibt es auch einen Lösungsansatz den ich Dir hier aber nicht offiziell rate oder erwähne. Lass aber mal hören ob es so geklappt hat.

Grüße
Holger
Signaturfreier Bereich! Außerdem....
wenn die Klügeren immer nachgeben, regieren am Ende die Dummen die Welt!

  • »DJ-Grafiboy« ist männlich

Beiträge: 1 652

Registrierungsdatum: 04.01.2004

Wohnort: Frankfurt am Main

Beruf: IT-Allrounder

Hobbys: Motorrad, Computer, Linux, Musik, Astronomie, Boxenbau, Technik aller Art

Danksagungen: 1786 / 1
(erhalten / vergeben)

  • Nachricht senden

8

13.03.2011, 11:01

Immer diese inoffiziellen Lösungsansätze.. :twisted:

Wenn Du Windows 7 Ultimate hast, kannst Du dir doch einfach die Windows XP VM herunterladen und das Spiel darauf ausführen. Hat den Vorteil, dass es auch sauber lizensiert ist.
Ich habe für solche Anwendungen den guten alten Windows XP PC, welcher auch mit Hardware aus der damaligen Zeit ausgestattet ist. Bei so alten Kisten lohnt sich der Verkauf sowiso nicht mehr..
1) Googlen könnt Ihr auch selber!
2) Wenn Ihr irgendwas nicht verstanden habt, dann fragt hier freundlich nach - wir werden sicher eine Lösung finden...
3) Erledigt die Punkte 1 und 2 BEVOR Ihr irgendwas kauft!

Holger

Administrator

  • »Holger« ist männlich

Beiträge: 4 651

Registrierungsdatum: 16.10.2002

Wohnort: Leer/Emden/Aurich

Beruf: Ja, hab ich auch...

Hobbys: Alles, außer Computer ;-)

Danksagungen: 3099 / 7
(erhalten / vergeben)

  • Nachricht senden

9

13.03.2011, 11:57

Auch mit der Inoffiziellen Lösung ist noch alles sauber lizenziert solange das Original vorhanden ist. Da wollen wir die Kirche mal im Ort lassen.

Und die VM für Spiele zu benutzen halte ich für nicht so eine tolle Idee. Die Grafikkarte die von VMWare emuliert wird, schafft es gerade noch so 2D halbwegs flüssig darzustellen. Vom 3D kann da überhaupt keine Rede sein.

Und auch Benutzer mit XP berichten bei AOE davon das es teilweise nicht läuft. Eine alte Kiste mit XP muss also nicht unbedingt hilfreich sein.

@DerNeue87
mal probeweise Zonealarm für das Spiel deaktiviert? Nur um das mal als Ursache auszuschliessen. Wenn Du ganz sicher gehen willst kannst ja LAN-Kabel mal abziehen.
Signaturfreier Bereich! Außerdem....
wenn die Klügeren immer nachgeben, regieren am Ende die Dummen die Welt!

  • »DJ-Grafiboy« ist männlich

Beiträge: 1 652

Registrierungsdatum: 04.01.2004

Wohnort: Frankfurt am Main

Beruf: IT-Allrounder

Hobbys: Motorrad, Computer, Linux, Musik, Astronomie, Boxenbau, Technik aller Art

Danksagungen: 1786 / 1
(erhalten / vergeben)

  • Nachricht senden

10

13.03.2011, 12:51

@Holger

Mit sauber lizensiert war nicht der Workarround gemeint, sondern die von Microsoft bereitgestellte Windows XP VM. Wenn man Windows XP über VMware (in meinen Augen sinnlos) oder VirtualBox als separete VM installiert, benötigt man ja neben der Windows-Lizenz für den Wirt (Host) auch eine Windows-Lizenz für den Gast (Windows VM).

Ich lasse die Kirche eigentlich immer im Dorf.. :grin:

Die beste Performance bei der Virtualisierung für den Privatanwender bietet im Moment VirtualBox. Es ist zudem kostenlos nutzbar für Privatanwender. Die Hardwarebeschleunigung für die Grafik ist möglich - allerdings lege ich dafür nicht die Hand ins Feuer.
1) Googlen könnt Ihr auch selber!
2) Wenn Ihr irgendwas nicht verstanden habt, dann fragt hier freundlich nach - wir werden sicher eine Lösung finden...
3) Erledigt die Punkte 1 und 2 BEVOR Ihr irgendwas kauft!

DerNeue87

Anfänger

  • »DerNeue87« ist der Autor dieses Themas

Beiträge: 5

Registrierungsdatum: 12.03.2011

Danksagungen: 55 / 0
(erhalten / vergeben)

  • Nachricht senden

11

13.03.2011, 19:59

Also bevor ich zusätzliche 500 MB auf`n Laptop ziehe und das für ein Spiel, werde ich lieber mal das mitm ZoneAlarm testen. Hatte ja davor XP drauf und es ging erste Sahne ;)

Beiträge: 126

Registrierungsdatum: 14.02.2009

Danksagungen: 453 / 3
(erhalten / vergeben)

  • Nachricht senden

12

17.08.2011, 13:13

So dann will ich mich hier auch einmal einklinken, ich habe auch mit dem Spiel Probleme gehabt und nach einiger Zeit und nach etlichem rumtüffteln hat sich das gelegt.

Bei mir war zwar nicht ganz das selbe Problem, das Spiel hat sich immer erst beim Spielen aufgehangen.


Letztendlich hat mir folgendes geholfen, da zu den anderen Möglichkeiten schon Holger ausgelassen hat will ich mich da nicht noch einmischen, denn mit solchen Dingen habe ich mich auch lange abgemüht ob es im Endeffekt was gebracht hat kann ich nicht sagen. Aber die Lösung des Problems war die Beendigung des Explorers vor dem Spielstart.

Alternativ kann man dazu auch eine .bat Datei schreiben, wenn du dich damit nicht so sehr auskennst kann ich dir die auch gerne schicken.

Vielleicht hat dir das ja weitergeholfen, seitdem funktioniert mein geliebtes Spiele Age of Empires 2 wieder.

Gruß
Gipfelstürmer

derNeue2

Anfänger

Beiträge: 1

Registrierungsdatum: 17.03.2012

Danksagungen: 9 / 0
(erhalten / vergeben)

  • Nachricht senden

13

17.03.2012, 10:06

hi musste mich nun auch hier anmelden,
Also ich habe exakt das gleiche Problem. Nur hab ich AoE 2 schon mal auf meinem Pc gespielt und mein pc ist ein windows xP. Ich hatte es deinstalliert und nach 1-2 Monaten wollte ich es spielen und dieses Problem ist aufgetreten. Somit kann es meiner meinung nach nicht an windows 7 ligen

Social bookmarks